aboutsummaryrefslogtreecommitdiff
path: root/system/Attic/Attic.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'system/Attic/Attic.SlackBuild')
-rw-r--r--system/Attic/Attic.SlackBuild7
1 files changed, 7 insertions, 0 deletions
diff --git a/system/Attic/Attic.SlackBuild b/system/Attic/Attic.SlackBuild
index 05f6254f3a62..e721261435a7 100644
--- a/system/Attic/Attic.SlackBuild
+++ b/system/Attic/Attic.SlackBuild
@@ -73,6 +73,8 @@ cd $TMP
rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
+# thanks void maintainers
+patch -p1 -i $CWD/openssl.diff
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
@@ -80,6 +82,11 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+for _file in attic/*.pyx; do
+ rm ${_file/pyx/c}
+done
+
+python3 setup.py sdist
python3 setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \