aboutsummaryrefslogtreecommitdiff
path: root/python
diff options
context:
space:
mode:
Diffstat (limited to 'python')
-rw-r--r--python/pipdeptree/pipdeptree.SlackBuild3
1 files changed, 2 insertions, 1 deletions
diff --git a/python/pipdeptree/pipdeptree.SlackBuild b/python/pipdeptree/pipdeptree.SlackBuild
index 2369d15c15..1f6d8cf8ec 100644
--- a/python/pipdeptree/pipdeptree.SlackBuild
+++ b/python/pipdeptree/pipdeptree.SlackBuild
@@ -69,7 +69,8 @@ find -L . \
# lower version requirement for pip
sed -i 's/pip>=23.1.2/pip>=21.3.1/' pyproject.toml
-export PYTHONPATH=/opt/python3.9/site-packages/
+PYVER=$(python3 -c 'import sys; print("%d.%d" % sys.version_info[:2])')
+export PYTHONPATH=/opt/python$PYVER/site-packages/
python3 -m build --no-isolation
python3 -m installer -d "$PKG" dist/*.whl