aboutsummaryrefslogtreecommitdiff
path: root/python
diff options
context:
space:
mode:
Diffstat (limited to 'python')
-rw-r--r--python/python3-socks/python3-socks.SlackBuild10
-rw-r--r--python/python3-socks/python3-socks.info8
2 files changed, 11 insertions, 7 deletions
diff --git a/python/python3-socks/python3-socks.SlackBuild b/python/python3-socks/python3-socks.SlackBuild
index 084bb29a03..6e400ad6b6 100644
--- a/python/python3-socks/python3-socks.SlackBuild
+++ b/python/python3-socks/python3-socks.SlackBuild
@@ -3,7 +3,7 @@
# Slackware build script for python3-socks
# Copyright 2019-2023 Isaac Yu <isaacyu@protonmail.com>
-# Copyright 2023-2024 nomnombtc <nomnombtc@arcor.de>
+# Copyright 2023-2025 nomnombtc <nomnombtc@arcor.de>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -26,7 +26,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=python3-socks
-VERSION=${VERSION:-2.5.3}
+VERSION=${VERSION:-2.6.1}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -82,7 +82,11 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python3 setup.py install --root=$PKG
+PYVER=$(python3 -c 'import sys; print("%d.%d" % sys.version_info[:2])')
+export PYTHONPATH=/opt/python$PYVER/site-packages
+
+python3 -m build --wheel --no-isolation
+python3 -m installer --destdir "$PKG" dist/*.whl
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
diff --git a/python/python3-socks/python3-socks.info b/python/python3-socks/python3-socks.info
index 47ff94482a..c743988d1a 100644
--- a/python/python3-socks/python3-socks.info
+++ b/python/python3-socks/python3-socks.info
@@ -1,10 +1,10 @@
PRGNAM="python3-socks"
-VERSION="2.5.3"
+VERSION="2.6.1"
HOMEPAGE="https://github.com/romis2012/python-socks/"
-DOWNLOAD="https://github.com/romis2012/python-socks/archive/v2.5.3/python-socks-2.5.3.tar.gz"
-MD5SUM="123afb3b78a93871f5c04219f2ae23a4"
+DOWNLOAD="https://github.com/romis2012/python-socks/archive/v2.6.1/python-socks-2.6.1.tar.gz"
+MD5SUM="94ede67e7d4743b490f11422d7160744"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES=""
+REQUIRES="python3-setuptools-opt"
MAINTAINER="nomnombtc"
EMAIL="nomnombtc@arcor.de"