aboutsummaryrefslogtreecommitdiff
path: root/python
diff options
context:
space:
mode:
Diffstat (limited to 'python')
-rw-r--r--python/python3-incremental/python3-incremental.SlackBuild7
-rw-r--r--python/python3-incremental/python3-incremental.info8
2 files changed, 9 insertions, 6 deletions
diff --git a/python/python3-incremental/python3-incremental.SlackBuild b/python/python3-incremental/python3-incremental.SlackBuild
index 06c1f3d75a..0b4e66f056 100644
--- a/python/python3-incremental/python3-incremental.SlackBuild
+++ b/python/python3-incremental/python3-incremental.SlackBuild
@@ -26,7 +26,7 @@ cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=python3-incremental
SRCNAM=${PRGNAM#python3-*}
-VERSION=${VERSION:-22.10.0}
+VERSION=${VERSION:-24.7.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -63,7 +63,10 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python3 setup.py install --root=$PKG
+PYVER=$(python3 -c 'import sys; print("%d.%d" % sys.version_info[:2])')
+export PYTHONPATH=/opt/python$PYVER/site-packages/
+python3 -m build --no-isolation
+python3 -m installer -d "$PKG" dist/*.whl
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
diff --git a/python/python3-incremental/python3-incremental.info b/python/python3-incremental/python3-incremental.info
index 792a0fa135..23574607e0 100644
--- a/python/python3-incremental/python3-incremental.info
+++ b/python/python3-incremental/python3-incremental.info
@@ -1,10 +1,10 @@
PRGNAM="python3-incremental"
-VERSION="22.10.0"
+VERSION="24.7.0"
HOMEPAGE="https://pypi.org/project/incremental/"
-DOWNLOAD="https://pypi.python.org/packages/source/i/incremental/incremental-22.10.0.tar.gz"
-MD5SUM="9fffa2490ca649550c79a78e85ef2eef"
+DOWNLOAD="https://pypi.python.org/packages/source/i/incremental/incremental-24.7.0.tar.gz"
+MD5SUM="2d99430f279b04f66c1386f66ad7ec2d"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES=""
+REQUIRES="python3-setuptools-opt"
MAINTAINER="Yth - Arnaud"
EMAIL="yth@ythogtha.org"