aboutsummaryrefslogtreecommitdiff
path: root/python
diff options
context:
space:
mode:
Diffstat (limited to 'python')
-rw-r--r--python/six/README6
-rw-r--r--python/six/six.SlackBuild10
-rw-r--r--python/six/six.info6
3 files changed, 7 insertions, 15 deletions
diff --git a/python/six/README b/python/six/README
index e968d08d27a5c..e995a974e8563 100644
--- a/python/six/README
+++ b/python/six/README
@@ -3,8 +3,4 @@ smoothing over the differences between the Python versions with the goal of
writing Python code that is compatible on both Python versions. See the
documentation for more information on what is provided.
-Optional dependencies: python3 and Sphinx
-
-Note: To install python3 bindings pass PYTHON3=yes to the slackbuild.
-
- # PYTHON3=yes ./six.SlackBuild
+Optional dependencies: Sphinx
diff --git a/python/six/six.SlackBuild b/python/six/six.SlackBuild
index 69506ba6ccfad..f4f61c16ca630 100644
--- a/python/six/six.SlackBuild
+++ b/python/six/six.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for six
-# Copyright 2012-2015 Larry Hajali <larryhaja[at]gmail[dot]com>
+# Copyright 2012-2017 Larry Hajali <larryhaja[at]gmail[dot]com>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -23,7 +23,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=six
-VERSION=${VERSION:-1.10.0}
+VERSION=${VERSION:-1.11.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -57,10 +57,6 @@ find -L . \
python setup.py install --root=$PKG
-if [ "${PYTHON3:-no}" == "yes" ]; then
- python3 setup.py install --root=$PKG
-fi
-
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
@@ -72,7 +68,7 @@ if $(python -c 'import sphinx.pygments_styles' 2>/dev/null); then
fi
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a LICENSE PKG-INFO README $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a LICENSE PKG-INFO README.rst $PKG/usr/doc/$PRGNAM-$VERSION
[ -d documentation/_build/singlehtml ] && \
cp -a documentation/_build/singlehtml/index.html \
documentation/_build/singlehtml/_static \
diff --git a/python/six/six.info b/python/six/six.info
index ac1dfc2093b42..32ec3507b74f7 100644
--- a/python/six/six.info
+++ b/python/six/six.info
@@ -1,8 +1,8 @@
PRGNAM="six"
-VERSION="1.10.0"
+VERSION="1.11.0"
HOMEPAGE="https://pypi.python.org/pypi/six/"
-DOWNLOAD="https://pypi.python.org/packages/source/s/six/six-1.10.0.tar.gz"
-MD5SUM="34eed507548117b2ab523ab14b2f8b55"
+DOWNLOAD="https://pypi.python.org/packages/16/d8/bc6316cf98419719bd59c91742194c111b6f2e85abac88e496adefaf7afe/six-1.11.0.tar.gz"
+MD5SUM="d12789f9baf7e9fb2524c0c64f1773f8"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""