aboutsummaryrefslogtreecommitdiff
path: root/python
diff options
context:
space:
mode:
Diffstat (limited to 'python')
-rw-r--r--python/six/README8
-rw-r--r--python/six/six.SlackBuild4
2 files changed, 7 insertions, 5 deletions
diff --git a/python/six/README b/python/six/README
index 4f3306550f75c..e968d08d27a5c 100644
--- a/python/six/README
+++ b/python/six/README
@@ -3,6 +3,8 @@ smoothing over the differences between the Python versions with the goal of
writing Python code that is compatible on both Python versions. See the
documentation for more information on what is provided.
-Optional: html documentation and man pages will be installed if Pygments and
-Sphinx are installed. Python3 module will be built if Python3 is installed.
-Pysetuptools is an optional build time dependency.
+Optional dependencies: python3 and Sphinx
+
+Note: To install python3 bindings pass PYTHON3=yes to the slackbuild.
+
+ # PYTHON3=yes ./six.SlackBuild
diff --git a/python/six/six.SlackBuild b/python/six/six.SlackBuild
index b1c25a1eaf019..69506ba6ccfad 100644
--- a/python/six/six.SlackBuild
+++ b/python/six/six.SlackBuild
@@ -29,7 +29,7 @@ TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
- i?86) ARCH=i486 ;;
+ i?86) ARCH=i586 ;;
arm*) ARCH=arm ;;
*) ARCH=$( uname -m ) ;;
esac
@@ -57,7 +57,7 @@ find -L . \
python setup.py install --root=$PKG
-if $(python3 -c 'import os' 2>/dev/null); then
+if [ "${PYTHON3:-no}" == "yes" ]; then
python3 setup.py install --root=$PKG
fi