aboutsummaryrefslogtreecommitdiff
path: root/python
diff options
context:
space:
mode:
Diffstat (limited to 'python')
-rw-r--r--python/cssselect/README4
-rw-r--r--python/cssselect/cssselect.SlackBuild5
2 files changed, 1 insertions, 8 deletions
diff --git a/python/cssselect/README b/python/cssselect/README
index a6e5144f1391b..0044035c47bb9 100644
--- a/python/cssselect/README
+++ b/python/cssselect/README
@@ -3,7 +3,3 @@ expressions. Such expressions can be used in lxml or another XPath
engine to find the matching elements in an XML or HTML document.
Optional dependencies: lxml and Sphinx
-
-Note: To install Python 3 bindings, install python3 and set
-PYTHON3="yes" in the environment:
- # PYTHON3="yes" ./cssselect.SlackBuild
diff --git a/python/cssselect/cssselect.SlackBuild b/python/cssselect/cssselect.SlackBuild
index eefb6cd691270..710eb6828da7d 100644
--- a/python/cssselect/cssselect.SlackBuild
+++ b/python/cssselect/cssselect.SlackBuild
@@ -66,10 +66,7 @@ find -L . \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
python setup.py install --root=$PKG
-
-if [ "${PYTHON3:-no}" == "yes" ]; then
- python3 setup.py install --root=$PKG
-fi
+python3 setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true