aboutsummaryrefslogtreecommitdiff
path: root/python/subprocess32/subprocess32.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'python/subprocess32/subprocess32.SlackBuild')
-rw-r--r--python/subprocess32/subprocess32.SlackBuild8
1 files changed, 4 insertions, 4 deletions
diff --git a/python/subprocess32/subprocess32.SlackBuild b/python/subprocess32/subprocess32.SlackBuild
index f7d44f8c58517..48b6102f1ea79 100644
--- a/python/subprocess32/subprocess32.SlackBuild
+++ b/python/subprocess32/subprocess32.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for subprocess32
-# Copyright 2018 Serban Udrea <s.udrea@gsi.de>
+# Copyright 2018-2022 Serban Udrea <s.udrea@gsi.de>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification,
@@ -26,8 +26,8 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=subprocess32
-VERSION=${VERSION:-3.5.2}
-BUILD=${BUILD:-2}
+VERSION=${VERSION:-3.5.4}
+BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -66,7 +66,7 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python setup.py install --root $PKG
+python2 setup.py install --root $PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true