aboutsummaryrefslogtreecommitdiff
path: root/python/schema/schema.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'python/schema/schema.SlackBuild')
-rw-r--r--python/schema/schema.SlackBuild6
1 files changed, 1 insertions, 5 deletions
diff --git a/python/schema/schema.SlackBuild b/python/schema/schema.SlackBuild
index 57f4025a45699..d422bfe960318 100644
--- a/python/schema/schema.SlackBuild
+++ b/python/schema/schema.SlackBuild
@@ -69,11 +69,7 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-if $(python3 -c 'import sys' 2>/dev/null); then
- python3 setup.py install --root=$PKG
-else
- python setup.py install --root=$PKG
-fi
+python3 setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true