aboutsummaryrefslogtreecommitdiff
path: root/python/python3-url-normalize/python3-url-normalize.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'python/python3-url-normalize/python3-url-normalize.SlackBuild')
-rw-r--r--python/python3-url-normalize/python3-url-normalize.SlackBuild25
1 files changed, 5 insertions, 20 deletions
diff --git a/python/python3-url-normalize/python3-url-normalize.SlackBuild b/python/python3-url-normalize/python3-url-normalize.SlackBuild
index b99bad36fb..ba98518080 100644
--- a/python/python3-url-normalize/python3-url-normalize.SlackBuild
+++ b/python/python3-url-normalize/python3-url-normalize.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for python3-url-normalize
-# Copyright 2023 fourtysixandtwo <fourtysixandtwo@sliderr.net>
+# Copyright 2023-2025 fourtysixandtwo <fourtysixandtwo@sliderr.net>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -25,8 +25,8 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=python3-url-normalize
-SRCNAM=${PRGNAM#python3-*}
-VERSION=${VERSION:-1.4.3}
+SRCNAM=url_normalize
+VERSION=${VERSION:-2.2.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -48,20 +48,6 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
set -e
rm -rf $PKG
@@ -77,9 +63,8 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \+
-#change backend to poetry-core (1.4.3 is last version this is needed)
-sed -i -e "/^build-backend / s/poetry.masonry.api/poetry.core.masonry.api/" \
- -e "/^requires / s/poetry>=0.12/poetry-core>=1.1.0/" pyproject.toml
+PYVER=$(python3 -c 'import sys; print("%d.%d" % sys.version_info[:2])')
+export PYTHONPATH=/opt/python$PYVER/site-packages
python3 -m build --no-isolation
python3 -m installer -d "$PKG" dist/*.whl