aboutsummaryrefslogtreecommitdiff
path: root/python/python3-tinydb/python3-tinydb.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'python/python3-tinydb/python3-tinydb.SlackBuild')
-rw-r--r--python/python3-tinydb/python3-tinydb.SlackBuild8
1 files changed, 4 insertions, 4 deletions
diff --git a/python/python3-tinydb/python3-tinydb.SlackBuild b/python/python3-tinydb/python3-tinydb.SlackBuild
index c2ee8fff160d3..2012eafabea70 100644
--- a/python/python3-tinydb/python3-tinydb.SlackBuild
+++ b/python/python3-tinydb/python3-tinydb.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for python3-tinydb
-# Copyright 2023 Dimitris Zlatanidis Orestiada, Greece
+# Copyright 2023-2024 Dimitris Zlatanidis Orestiada, Greece
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -26,7 +26,7 @@ cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=python3-tinydb
SRCNAM=tinydb
-VERSION=${VERSION:-4.7.1}
+VERSION=${VERSION:-4.8.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -77,12 +77,12 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python3 setup.py install --root=$PKG
+python3 -m build --wheel --no-isolation
+python3 -m installer --destdir "$PKG" dist/*.whl
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a LICENSE README.rst $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild