aboutsummaryrefslogtreecommitdiff
path: root/python/python3-sge/python3-sge.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'python/python3-sge/python3-sge.SlackBuild')
-rw-r--r--python/python3-sge/python3-sge.SlackBuild105
1 files changed, 105 insertions, 0 deletions
diff --git a/python/python3-sge/python3-sge.SlackBuild b/python/python3-sge/python3-sge.SlackBuild
new file mode 100644
index 000000000000..355f2dc4187a
--- /dev/null
+++ b/python/python3-sge/python3-sge.SlackBuild
@@ -0,0 +1,105 @@
+#!/bin/bash
+
+# Slackware build script for python3-sge
+
+# Written by B. Watson (yalhcru@gmail.com)
+
+# Licensed under the WTFPL. See http://www.wtfpl.net/txt/copying/ for details.
+
+cd $(dirname $0) ; CWD=$(pwd)
+
+PRGNAM=python3-sge
+VERSION=${VERSION:-2.0.post0}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+SRCNAM=sge
+XVER=2021.10.11
+
+fixperms() {
+ chown -R root:root .
+ find -L . -perm /111 -a \! -perm 755 -a -exec chmod 755 {} \+ -o \
+ \! -perm /111 -a \! -perm 644 -a -exec chmod 644 {} \+
+}
+
+# First, sge itself...
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM-$VERSION
+fixperms
+
+python3 setup.py install --root=$PKG
+
+PKGDOC=$PKG/usr/doc/$PRGNAM-$VERSION
+mkdir -p $PKGDOC/html
+
+# only build the HTML docs if Sphinx is installed.
+HASDOC="does NOT include"
+if type -p sphinx-build &>/dev/null; then
+ HASDOC="includes"
+ make -C doc-src html
+ cp -a doc/html $PKGDOC/html/sge
+fi
+
+cp -a README* WHATS* VERS* examples $SRCNAM/COPY* $PKGDOC
+cat $CWD/$PRGNAM.SlackBuild > $PKGDOC/$PRGNAM.SlackBuild
+
+# Now the extensions (xsge).
+cd $TMP
+rm -rf xsge-$XVER
+tar xvf $CWD/xsge-$XVER.tar.gz
+cd xsge-$XVER
+fixperms
+
+python3 setup.py install --root=$PKG
+
+# HTML docs for xsge are prebuilt.
+for i in */; do
+ cp -a $i/doc/html $PKGDOC/html/$i
+done
+
+cp -a README $PKGDOC/README.xsge
+
+mkdir -p $PKG/install
+sed "s,@HASDOC@,$HASDOC," $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE