aboutsummaryrefslogtreecommitdiff
path: root/python/python3-pyproject-api/python3-pyproject-api.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'python/python3-pyproject-api/python3-pyproject-api.SlackBuild')
-rw-r--r--python/python3-pyproject-api/python3-pyproject-api.SlackBuild5
1 files changed, 4 insertions, 1 deletions
diff --git a/python/python3-pyproject-api/python3-pyproject-api.SlackBuild b/python/python3-pyproject-api/python3-pyproject-api.SlackBuild
index 715c2314fc08..fef1bf53181e 100644
--- a/python/python3-pyproject-api/python3-pyproject-api.SlackBuild
+++ b/python/python3-pyproject-api/python3-pyproject-api.SlackBuild
@@ -24,7 +24,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=python3-pyproject-api
-VERSION=${VERSION:-1.7.1}
+VERSION=${VERSION:-1.8.0}
SRCNAM=${SRCNAM:-pyproject-api}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -69,6 +69,9 @@ export SETUPTOOLS_SCM_PRETEND_VERSION=$VERSION
# Revert unnecessary dependency version requirements
sed -i 's|2\.0\.1|1\.2\.2|' pyproject.toml # tomli
+# Hide warning for packaging>=24 since it resides in /opt/
+sed -i 's|.*packaging.*||' pyproject.toml
+
python3 -m build --wheel --no-isolation
python3 -m installer --destdir=$PKG dist/*.whl