aboutsummaryrefslogtreecommitdiff
path: root/python/python3-putio.py
diff options
context:
space:
mode:
Diffstat (limited to 'python/python3-putio.py')
-rw-r--r--python/python3-putio.py/python3-putio.py.SlackBuild5
1 files changed, 4 insertions, 1 deletions
diff --git a/python/python3-putio.py/python3-putio.py.SlackBuild b/python/python3-putio.py/python3-putio.py.SlackBuild
index db7c597e4287e..88e4b5676732a 100644
--- a/python/python3-putio.py/python3-putio.py.SlackBuild
+++ b/python/python3-putio.py/python3-putio.py.SlackBuild
@@ -26,7 +26,7 @@ cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=python3-putio.py
SRCNAM=putio.py
VERSION=${VERSION:-8.7.0}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -76,6 +76,9 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+# Fix building from source
+sed -i "s/'0'/\'$VERSION\'/" setup.py
+
python3 setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \