aboutsummaryrefslogtreecommitdiff
path: root/python/python3-pandas/python3-pandas.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'python/python3-pandas/python3-pandas.SlackBuild')
-rw-r--r--python/python3-pandas/python3-pandas.SlackBuild18
1 files changed, 15 insertions, 3 deletions
diff --git a/python/python3-pandas/python3-pandas.SlackBuild b/python/python3-pandas/python3-pandas.SlackBuild
index df9305bf70..480c33e84f 100644
--- a/python/python3-pandas/python3-pandas.SlackBuild
+++ b/python/python3-pandas/python3-pandas.SlackBuild
@@ -28,7 +28,7 @@ cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=python3-pandas
SRCNAM=pandas
-VERSION=${VERSION:-1.4.2}
+VERSION=${VERSION:-2.1.1}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -65,14 +65,26 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python3 setup.py install --root=$PKG
+# remove requirement
+sed -i '/oldest-supported-numpy/d' pyproject.toml
+
+# convert to minimum req'd instead of pinned
+sed -i 's/meson-python==/meson-python>=/' pyproject.toml
+sed -i 's/meson==/meson>=/' pyproject.toml
+
+# needs newer meson
+export PYTHONPATH=/opt/python3.9/site-packages/
+
+# cannot build sdist, specify just wheel
+python3 -m build --wheel --no-isolation
+python3 -m installer -d "$PKG" dist/*.whl
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a \
- LICENSE PKG-INFO README.md RELEASE.md \
+ AUTHORS.md LICENSE PKG-INFO README.md \
$PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild