aboutsummaryrefslogtreecommitdiff
path: root/python/python3-lazy_loader/python3-lazy_loader.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'python/python3-lazy_loader/python3-lazy_loader.SlackBuild')
-rw-r--r--python/python3-lazy_loader/python3-lazy_loader.SlackBuild33
1 files changed, 16 insertions, 17 deletions
diff --git a/python/python3-lazy_loader/python3-lazy_loader.SlackBuild b/python/python3-lazy_loader/python3-lazy_loader.SlackBuild
index b323f3ec8b..785828adfa 100644
--- a/python/python3-lazy_loader/python3-lazy_loader.SlackBuild
+++ b/python/python3-lazy_loader/python3-lazy_loader.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for python3-lazy_loader
-# Copyright 2023 Jeremy Hansen jebrhansen+SBo@gmail.com
+# Copyright 2023-2024 Jeremy Hansen <jebrhansen+SBo@gmail.com>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -24,7 +24,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=python3-lazy_loader
-VERSION=${VERSION:-0.3}
+VERSION=${VERSION:-0.4}
SRCNAM=${SRCNAM:-lazy_loader}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -47,20 +47,6 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
set -e
rm -rf $PKG
@@ -76,7 +62,20 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-# For no setup.py (requires wheel & python3-installer as dependencies)
+# Use separate setuptools
+PYVER=$(python3 -c 'import sys; print("%d.%d" % sys.version_info[:2])')
+export PYTHONPATH=/opt/python$PYVER/site-packages
+
+# Add unused section to avoid ERROR message from setuptools_scm
+# Make it an if statement just in case upstream decides to update
+# it and I don't notice.
+if ! grep -qF "[tool.setuptools_scm]" pyproject.toml; then
+ echo "[tool.setuptools_scm]" >> pyproject.toml
+fi
+
+# Let setuptools-scm know what the version is without requiring pypi source
+export SETUPTOOLS_SCM_PRETEND_VERSION=$VERSION
+
python3 -m build --wheel --no-isolation
python3 -m installer --destdir=$PKG dist/*.whl