aboutsummaryrefslogtreecommitdiff
path: root/python/python3-json5/python3-json5.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'python/python3-json5/python3-json5.SlackBuild')
-rw-r--r--python/python3-json5/python3-json5.SlackBuild7
1 files changed, 5 insertions, 2 deletions
diff --git a/python/python3-json5/python3-json5.SlackBuild b/python/python3-json5/python3-json5.SlackBuild
index f96f3f56f5f6a..2e64b188421f3 100644
--- a/python/python3-json5/python3-json5.SlackBuild
+++ b/python/python3-json5/python3-json5.SlackBuild
@@ -27,7 +27,7 @@ cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=python3-json5
VERSION=${VERSION:-0.9.17}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -65,7 +65,10 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python3 setup.py install --root=$PKG
+export PYTHONPATH=/opt/python3.9/site-packages/
+
+python3 -m build --no-isolation
+python3 -m installer -d "$PKG" dist/*.whl
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true