aboutsummaryrefslogtreecommitdiff
path: root/python/python3-dnspython/python3-dnspython.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'python/python3-dnspython/python3-dnspython.SlackBuild')
-rw-r--r--python/python3-dnspython/python3-dnspython.SlackBuild5
1 files changed, 3 insertions, 2 deletions
diff --git a/python/python3-dnspython/python3-dnspython.SlackBuild b/python/python3-dnspython/python3-dnspython.SlackBuild
index e745a3f9ec..1ebf3460d9 100644
--- a/python/python3-dnspython/python3-dnspython.SlackBuild
+++ b/python/python3-dnspython/python3-dnspython.SlackBuild
@@ -27,7 +27,7 @@ cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=python3-dnspython
SRCNAM=${PRGNAM#python3-*}
-VERSION=${VERSION:-2.3.0}
+VERSION=${VERSION:-2.4.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -64,7 +64,8 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python3 setup.py install --root=$PKG
+python3 -m build --no-isolation
+python3 -m installer -d "$PKG" dist/*.whl
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true