aboutsummaryrefslogtreecommitdiff
path: root/python/python3-aiohttp-socks
diff options
context:
space:
mode:
Diffstat (limited to 'python/python3-aiohttp-socks')
-rw-r--r--python/python3-aiohttp-socks/python3-aiohttp-socks.SlackBuild8
-rw-r--r--python/python3-aiohttp-socks/python3-aiohttp-socks.info8
2 files changed, 10 insertions, 6 deletions
diff --git a/python/python3-aiohttp-socks/python3-aiohttp-socks.SlackBuild b/python/python3-aiohttp-socks/python3-aiohttp-socks.SlackBuild
index 16889936a3..9d4ed7161e 100644
--- a/python/python3-aiohttp-socks/python3-aiohttp-socks.SlackBuild
+++ b/python/python3-aiohttp-socks/python3-aiohttp-socks.SlackBuild
@@ -26,7 +26,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=python3-aiohttp-socks
-VERSION=${VERSION:-0.9.0}
+VERSION=${VERSION:-0.10.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -82,7 +82,11 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python3 setup.py install --root=$PKG
+PYVER=$(python3 -c 'import sys; print("%d.%d" % sys.version_info[:2])')
+export PYTHONPATH=/opt/python$PYVER/site-packages
+
+python3 -m build --wheel --no-isolation
+python3 -m installer --destdir "$PKG" dist/*.whl
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
diff --git a/python/python3-aiohttp-socks/python3-aiohttp-socks.info b/python/python3-aiohttp-socks/python3-aiohttp-socks.info
index dafbb3fe0f..f85ede4cbe 100644
--- a/python/python3-aiohttp-socks/python3-aiohttp-socks.info
+++ b/python/python3-aiohttp-socks/python3-aiohttp-socks.info
@@ -1,10 +1,10 @@
PRGNAM="python3-aiohttp-socks"
-VERSION="0.9.0"
+VERSION="0.10.0"
HOMEPAGE="https://github.com/romis2012/aiohttp-socks/"
-DOWNLOAD="https://github.com/romis2012/aiohttp-socks/archive/v0.9.0/aiohttp-socks-0.9.0.tar.gz"
-MD5SUM="391fa4d4b06fd877e5ef9de0692718bd"
+DOWNLOAD="https://github.com/romis2012/aiohttp-socks/archive/v0.10.0/aiohttp-socks-0.10.0.tar.gz"
+MD5SUM="612ef626bd0a7ebfb3dbdba156d4773d"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES="python3-aiohttp python3-socks"
+REQUIRES="python3-aiohttp python3-socks python3-setuptools-opt"
MAINTAINER="nomnombtc"
EMAIL="nomnombtc@arcor.de"