aboutsummaryrefslogtreecommitdiff
path: root/python/python-unicodedata2/python-unicodedata2.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'python/python-unicodedata2/python-unicodedata2.SlackBuild')
-rw-r--r--python/python-unicodedata2/python-unicodedata2.SlackBuild18
1 files changed, 6 insertions, 12 deletions
diff --git a/python/python-unicodedata2/python-unicodedata2.SlackBuild b/python/python-unicodedata2/python-unicodedata2.SlackBuild
index 1d776230dc..d85b893770 100644
--- a/python/python-unicodedata2/python-unicodedata2.SlackBuild
+++ b/python/python-unicodedata2/python-unicodedata2.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for python-unicodedata2
-# Copyright 2017-2020 Andrew Clemons, Wellington New Zealand
+# Copyright 2017-2020,2022 Andrew Clemons, Wellington New Zealand
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -26,8 +26,7 @@ cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=python-unicodedata2
SRCNAM=unicodedata2
-VERSION=${VERSION:-13.0.0_2}
-SRCVERSION=$(echo "$VERSION" | tr _ -)
+VERSION=${VERSION:-14.0.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -71,9 +70,9 @@ set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
-rm -rf $SRCNAM-$SRCVERSION
-tar xvf $CWD/$SRCNAM-$SRCVERSION.tar.gz
-cd $SRCNAM-$SRCVERSION
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
@@ -81,12 +80,7 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python setup.py install --root=$PKG
-
-# Python 3 support.
-if $(python3 -c 'import sys' 2>/dev/null); then
- python3 setup.py install --root=$PKG
-fi
+python3 setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true