aboutsummaryrefslogtreecommitdiff
path: root/python/python-parse
diff options
context:
space:
mode:
Diffstat (limited to 'python/python-parse')
-rw-r--r--python/python-parse/python-parse.SlackBuild17
-rw-r--r--python/python-parse/python-parse.info14
-rw-r--r--python/python-parse/slack-desc2
3 files changed, 16 insertions, 17 deletions
diff --git a/python/python-parse/python-parse.SlackBuild b/python/python-parse/python-parse.SlackBuild
index 51ec2dae49..84b9f16dc8 100644
--- a/python/python-parse/python-parse.SlackBuild
+++ b/python/python-parse/python-parse.SlackBuild
@@ -2,6 +2,7 @@
# SlackBuild script for "python-parse".
+# Copyright 2024 Sean Hinchee
# Copyright 2014-2015 Marcel Saegebarth <marc@mos6581.de>
# All rights reserved.
#
@@ -28,8 +29,8 @@ cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=python-parse
SRCNAM=parse
-VERSION=${VERSION:-1.6.6}
-BUILD=${BUILD:-4}
+VERSION=${VERSION:-1.20.2}
+BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -41,9 +42,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -82,11 +80,12 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python setup.py install --root=$PKG
+# newer releases use setuptools
+PYVER=$(python3 -c 'import sys; print("%d.%d" % sys.version_info[:2])')
+export PYTHONPATH=/opt/python$PYVER/site-packages
-if $(python3 -c 'import sys' 2>/dev/null); then
- python3 setup.py install --root=$PKG
-fi
+python3 -m build . --wheel --no-isolation # --root=$PKG
+python3 -m installer --destdir "$PKG" dist/*.whl
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a README.rst $PKG/usr/doc/$PRGNAM-$VERSION
diff --git a/python/python-parse/python-parse.info b/python/python-parse/python-parse.info
index 030c7adb07..20f52abe55 100644
--- a/python/python-parse/python-parse.info
+++ b/python/python-parse/python-parse.info
@@ -1,10 +1,10 @@
PRGNAM="python-parse"
-VERSION="1.6.6"
-HOMEPAGE="https://pypi.python.org/pypi/parse/"
-DOWNLOAD="https://pypi.python.org/packages/source/p/parse/parse-1.6.6.tar.gz"
-MD5SUM="11bc8c60a30fe52db4ac9a827653d0ca"
+VERSION="1.20.2"
+HOMEPAGE="https://github.com/r1chardj0n3s/parse"
+DOWNLOAD="https://github.com/r1chardj0n3s/parse/archive/1.20.2/parse-1.20.2.tar.gz"
+MD5SUM="312dc6f64acb96585f0523f8bde3181c"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES=""
-MAINTAINER="Marcel Saegebarth"
-EMAIL="marc@mos6581.de"
+REQUIRES="python3-setuptools-opt"
+MAINTAINER="Sean Hinchee"
+EMAIL="henesy.dev@gmail.com"
diff --git a/python/python-parse/slack-desc b/python/python-parse/slack-desc
index 9cb670fdcf..20392cb006 100644
--- a/python/python-parse/slack-desc
+++ b/python/python-parse/slack-desc
@@ -11,7 +11,7 @@ python-parse:
python-parse: Parse strings using a specification based on the Python format()
python-parse: syntax.
python-parse:
-python-parse: Homepage: https://pypi.python.org/pypi/parse/
+python-parse: Homepage: https://github.com/r1chardj0n3s/parse
python-parse:
python-parse:
python-parse: