aboutsummaryrefslogtreecommitdiff
path: root/python/python-mpmath/python-mpmath.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'python/python-mpmath/python-mpmath.SlackBuild')
-rw-r--r--python/python-mpmath/python-mpmath.SlackBuild10
1 files changed, 5 insertions, 5 deletions
diff --git a/python/python-mpmath/python-mpmath.SlackBuild b/python/python-mpmath/python-mpmath.SlackBuild
index e4982f1ebd..773142ea2e 100644
--- a/python/python-mpmath/python-mpmath.SlackBuild
+++ b/python/python-mpmath/python-mpmath.SlackBuild
@@ -3,7 +3,7 @@
# Slackware build script for python-mpmath
# Copyright SlackBuilds.org Project, David Melik, 2015, Spokane, WA, USA
-# Copyright 2019-2022, Alexander Verbovetsky, Moscow, Russia
+# Copyright 2019-2023, Alexander Verbovetsky, Moscow, Russia
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -27,8 +27,8 @@ cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=python-mpmath
SRCNAM=mpmath
-VERSION=${VERSION:-1.2.1}
-BUILD=${BUILD:-3}
+VERSION=${VERSION:-1.3.0}
+BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -80,7 +80,7 @@ find -L . \
python2 setup.py install --root=$PKG
-find ./ -type f -name '*.py' -exec \
+find -L ./ -type f -name '*.py' -exec \
sed -i -e 's|#!/usr/bin/python\>|#!/usr/bin/python3|' \
-e 's|#!/usr/bin/env python\>|#!/usr/bin/env python3|' {} \;
@@ -90,7 +90,7 @@ find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | gr
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a CHANGES LICENSE README.rst TODO $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a README.rst $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install