aboutsummaryrefslogtreecommitdiff
path: root/python/python-dateutil/python-dateutil-2.1-open-utf-8.patch
diff options
context:
space:
mode:
Diffstat (limited to 'python/python-dateutil/python-dateutil-2.1-open-utf-8.patch')
-rw-r--r--python/python-dateutil/python-dateutil-2.1-open-utf-8.patch20
1 files changed, 20 insertions, 0 deletions
diff --git a/python/python-dateutil/python-dateutil-2.1-open-utf-8.patch b/python/python-dateutil/python-dateutil-2.1-open-utf-8.patch
new file mode 100644
index 0000000000000..7b1784378f5d6
--- /dev/null
+++ b/python/python-dateutil/python-dateutil-2.1-open-utf-8.patch
@@ -0,0 +1,20 @@
+=== modified file 'setup.py'
+--- setup.py 2012-04-29 13:32:22 +0000
++++ setup.py 2012-04-29 13:34:16 +0000
+@@ -1,5 +1,6 @@
+ #!/usr/bin/python
+ from os.path import isfile, join
++import codecs
+ import glob
+ import os
+ import re
+@@ -13,7 +14,7 @@
+
+ TOPDIR = os.path.dirname(__file__) or "."
+ VERSION = re.search('__version__ = "([^"]+)"',
+- open(TOPDIR + "/dateutil/__init__.py").read()).group(1)
++ codecs.open(TOPDIR + "/dateutil/__init__.py", encoding='utf-8').read()).group(1)
+
+
+ setup(name="python-dateutil",
+