aboutsummaryrefslogtreecommitdiff
path: root/python/python-argopt/python-argopt.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'python/python-argopt/python-argopt.SlackBuild')
-rw-r--r--python/python-argopt/python-argopt.SlackBuild11
1 files changed, 3 insertions, 8 deletions
diff --git a/python/python-argopt/python-argopt.SlackBuild b/python/python-argopt/python-argopt.SlackBuild
index 1f2e839c73..6f749447e5 100644
--- a/python/python-argopt/python-argopt.SlackBuild
+++ b/python/python-argopt/python-argopt.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for python-argopt
-# Copyright 2018-2020 Andrew Clemons, Wellington New Zealand
+# Copyright 2018-2021 Andrew Clemons, Wellington New Zealand
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -26,7 +26,7 @@ cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=python-argopt
SRCNAM="$(echo "$PRGNAM" | cut -d- -f2)"
-VERSION=${VERSION:-0.6.0}
+VERSION=${VERSION:-0.7.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -80,13 +80,8 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-sed -i "s/\\(install_requires=\\)\\['argparse'\\]/\\1[]/g" setup.py
-
python setup.py install --root=$PKG
-
-if python3 -c 'import sys' 2> /dev/null ; then
- python3 setup.py install --root=$PKG
-fi
+python3 setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true