aboutsummaryrefslogtreecommitdiff
path: root/python/pysnmp
diff options
context:
space:
mode:
Diffstat (limited to 'python/pysnmp')
-rw-r--r--python/pysnmp/pysnmp.SlackBuild7
-rw-r--r--python/pysnmp/pysnmp.info2
2 files changed, 3 insertions, 6 deletions
diff --git a/python/pysnmp/pysnmp.SlackBuild b/python/pysnmp/pysnmp.SlackBuild
index 5fb3b8eafa78e..778f5a563f05d 100644
--- a/python/pysnmp/pysnmp.SlackBuild
+++ b/python/pysnmp/pysnmp.SlackBuild
@@ -27,7 +27,7 @@ cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=pysnmp
VERSION=${VERSION:-4.1.16d}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -39,9 +39,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -80,7 +77,7 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \;
-python setup.py install --root=$PKG
+python2 setup.py install --root=$PKG
find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
diff --git a/python/pysnmp/pysnmp.info b/python/pysnmp/pysnmp.info
index c389ab8175c82..91130222535c0 100644
--- a/python/pysnmp/pysnmp.info
+++ b/python/pysnmp/pysnmp.info
@@ -5,6 +5,6 @@ DOWNLOAD="https://downloads.sourceforge.net/pysnmp/pysnmp-4.1.16d.tar.gz"
MD5SUM="c8e015c3c1935294d2e235cee47768dc"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES="pyasn1 python2-pycrypto"
+REQUIRES="python2-pyasn1 python2-pycrypto"
MAINTAINER="Ilya Etingof"
EMAIL="ilya@glas.net"