aboutsummaryrefslogtreecommitdiff
path: root/python/plaso/plaso.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'python/plaso/plaso.SlackBuild')
-rw-r--r--python/plaso/plaso.SlackBuild8
1 files changed, 4 insertions, 4 deletions
diff --git a/python/plaso/plaso.SlackBuild b/python/plaso/plaso.SlackBuild
index 99af90bab295e..1946ee1849d99 100644
--- a/python/plaso/plaso.SlackBuild
+++ b/python/plaso/plaso.SlackBuild
@@ -1,7 +1,7 @@
#!/bin/bash
# Slackware build script for plaso
-# Copyright 2015-2019 Barry Grundy <bgrundy[at]linuxleo.com>
+# Copyright 2015-2022 Barry Grundy <bgrundy[at]linuxleo.com>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -21,12 +21,12 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
#
-# Updated Build version 20190131, March 2019
+# Updated Build version 20220428, May 2022
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=plaso
-VERSION=${VERSION:-20190131}
+VERSION=${VERSION:-20220428}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -80,7 +80,7 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python2 setup.py install --root=$PKG
+python3 setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true