aboutsummaryrefslogtreecommitdiff
path: root/python/pathlib2/pathlib2.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'python/pathlib2/pathlib2.SlackBuild')
-rw-r--r--python/pathlib2/pathlib2.SlackBuild6
1 files changed, 1 insertions, 5 deletions
diff --git a/python/pathlib2/pathlib2.SlackBuild b/python/pathlib2/pathlib2.SlackBuild
index 1619a30e0cc2..3a63b2f1621d 100644
--- a/python/pathlib2/pathlib2.SlackBuild
+++ b/python/pathlib2/pathlib2.SlackBuild
@@ -70,11 +70,7 @@ find -L . \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
python2 setup.py install --root=$PKG
-
-# Python 3 support.
-if $(python3 -c 'import sys' 2>/dev/null); then
- python3 setup.py install --root=$PKG
-fi
+python3 setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true