aboutsummaryrefslogtreecommitdiff
path: root/python/kombu
diff options
context:
space:
mode:
Diffstat (limited to 'python/kombu')
-rw-r--r--python/kombu/README12
-rw-r--r--python/kombu/kombu.SlackBuild6
2 files changed, 8 insertions, 10 deletions
diff --git a/python/kombu/README b/python/kombu/README
index f83d04ed2594..7df1347cb3fc 100644
--- a/python/kombu/README
+++ b/python/kombu/README
@@ -1,9 +1,9 @@
Kombu is a messaging library for Python.
-The aim of Kombu is to make messaging in Python as easy as possible by providing
-an idiomatic high-level interface for the AMQ protocol, and also provide proven
-and tested solutions to common messaging problems.
+The aim of Kombu is to make messaging in Python as easy as possible by
+providing an idiomatic high-level interface for the AMQ protocol, and
+also provide proven and tested solutions to common messaging problems.
-AMQP is the Advanced Message Queuing Protocol, an open standard protocol for
-message orientation, queuing, routing, reliability and security, for which the
-RabbitMQ messaging server is the most popular implementation.
+AMQP is the Advanced Message Queuing Protocol, an open standard protocol
+for message orientation, queuing, routing, reliability and security, for
+which the RabbitMQ messaging server is the most popular implementation.
diff --git a/python/kombu/kombu.SlackBuild b/python/kombu/kombu.SlackBuild
index 813390ba9383..f994b68def07 100644
--- a/python/kombu/kombu.SlackBuild
+++ b/python/kombu/kombu.SlackBuild
@@ -53,10 +53,8 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python setup.py install --root=$PKG
-if $(python3 -c 'import sys' 2>/dev/null); then
- python3 setup.py install --root=$PKG
-fi
+python2 setup.py install --root=$PKG
+python3 setup.py install --root=$PKG
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a README.rst $PKG/usr/doc/$PRGNAM-$VERSION