aboutsummaryrefslogtreecommitdiff
path: root/python/git-fame
diff options
context:
space:
mode:
Diffstat (limited to 'python/git-fame')
-rw-r--r--python/git-fame/git-fame.SlackBuild2
-rw-r--r--python/git-fame/git-fame.info2
2 files changed, 2 insertions, 2 deletions
diff --git a/python/git-fame/git-fame.SlackBuild b/python/git-fame/git-fame.SlackBuild
index a2f581d09a5f9..e47b27e62f19a 100644
--- a/python/git-fame/git-fame.SlackBuild
+++ b/python/git-fame/git-fame.SlackBuild
@@ -69,7 +69,7 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python setup.py install --root=$PKG
+python2 setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
diff --git a/python/git-fame/git-fame.info b/python/git-fame/git-fame.info
index 4e1a793dfe989..d2e6ea173de93 100644
--- a/python/git-fame/git-fame.info
+++ b/python/git-fame/git-fame.info
@@ -5,6 +5,6 @@ DOWNLOAD="https://files.pythonhosted.org/packages/00/b6/4eb0f863ecdd62e8a1544f5c
MD5SUM="5d4c8e0131022be52966aa25ffb48538"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES="python-argopt docopt tqdm python-tabulate"
+REQUIRES="python-argopt docopt tqdm python2-tabulate"
MAINTAINER="Andrew Clemons"
EMAIL="andrew.clemons@gmail.com"