aboutsummaryrefslogtreecommitdiff
path: root/python/feedparser/feedparser.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'python/feedparser/feedparser.SlackBuild')
-rw-r--r--python/feedparser/feedparser.SlackBuild17
1 files changed, 15 insertions, 2 deletions
diff --git a/python/feedparser/feedparser.SlackBuild b/python/feedparser/feedparser.SlackBuild
index 8f657c6a38ac4..3231c591958b2 100644
--- a/python/feedparser/feedparser.SlackBuild
+++ b/python/feedparser/feedparser.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for feedparser
# Modified by Luis Henrique <lmello.009@gmail.com>
-# Maintained 2014-2016 by Christoph Willing <chris.willing@linux.com>
+# Maintained 2014-2019 by Christoph Willing <chris.willing@linux.com>
# Copyright 2008-2009 Chess Griffin <chess@chessgriffin.com>
# All rights reserved.
@@ -64,7 +64,7 @@ rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM-$VERSION
-tar xf $CWD/$VERSION.tar.gz || tar xf $CWD/$PRGNAM-$VERSION.tar.gz
+tar xf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
@@ -75,6 +75,19 @@ find -L . \
python setup.py build
python setup.py install --root $PKG
+if $(python3 -c 'import sys' 2>/dev/null); then
+ # Python3 doesn't have sgmllib so we provide it here for building
+ # and later installation as part of the feedparser package.
+ cp feedparser/sgmllib3.py feedparser/sgmllib.py
+ PYTHONPATH=$(pwd)/feedparser:$PYTHONPATH
+
+ patch -p0 < $CWD/001_py37.diff
+ python3 setup.py build
+ python3 setup.py install --root $PKG
+
+ PYSITEDIR=$(python3 -c "import site; print(site.getsitepackages()[0])")
+ install -m 0644 feedparser/sgmllib.py $PKG/$PYSITEDIR
+fi
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true