aboutsummaryrefslogtreecommitdiff
path: root/python/feedparser/001_py37.diff
diff options
context:
space:
mode:
Diffstat (limited to 'python/feedparser/001_py37.diff')
-rw-r--r--python/feedparser/001_py37.diff23
1 files changed, 23 insertions, 0 deletions
diff --git a/python/feedparser/001_py37.diff b/python/feedparser/001_py37.diff
new file mode 100644
index 0000000000000..5182a5b2b8c86
--- /dev/null
+++ b/python/feedparser/001_py37.diff
@@ -0,0 +1,23 @@
+--- setup.py.orig 2015-07-24 15:00:04.000000000 +1000
++++ setup.py 2019-06-24 21:34:06.883000000 +1000
+@@ -35,6 +35,9 @@
+ 'Programming Language :: Python :: 3.2',
+ 'Programming Language :: Python :: 3.3',
+ 'Programming Language :: Python :: 3.4',
++ 'Programming Language :: Python :: 3.5',
++ 'Programming Language :: Python :: 3.6',
++ 'Programming Language :: Python :: 3.7',
+ 'Topic :: Software Development :: Libraries :: Python Modules',
+ 'Topic :: Text Processing :: Markup :: XML',
+ ],
+--- feedparser/feedparser.py.orig 2015-07-24 15:00:04.000000000 +1000
++++ feedparser/feedparser.py 2019-06-24 22:15:09.636000000 +1000
+@@ -130,6 +130,8 @@
+ #ACCEPTABLE_URI_SCHEMES = ()
+
+ # ---------- required modules (should come with any Python distribution) ----------
++from __future__ import absolute_import, unicode_literals
++
+ import cgi
+ import codecs
+ import copy