aboutsummaryrefslogtreecommitdiff
path: root/python/entrypoints/entrypoints.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'python/entrypoints/entrypoints.SlackBuild')
-rw-r--r--python/entrypoints/entrypoints.SlackBuild7
1 files changed, 4 insertions, 3 deletions
diff --git a/python/entrypoints/entrypoints.SlackBuild b/python/entrypoints/entrypoints.SlackBuild
index 19970b4334e6..5f6d246cc69b 100644
--- a/python/entrypoints/entrypoints.SlackBuild
+++ b/python/entrypoints/entrypoints.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for entrypoints
-# Copyright 2017 Benjamin Trigona-Harany <slackbuilds@jaxartes.net>
+# Copyright 2017-2018 Benjamin Trigona-Harany <slackbuilds@jaxartes.net>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -24,7 +24,7 @@
PRGNAM=entrypoints
VERSION=${VERSION:-0.2.3}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
@@ -70,7 +70,8 @@ find -L . \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
cp $CWD/setup.py .
-python setup.py install --root=$PKG
+python2 setup.py install --root=$PKG
+python3 setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true