aboutsummaryrefslogtreecommitdiff
path: root/python/ecdsa
diff options
context:
space:
mode:
Diffstat (limited to 'python/ecdsa')
-rw-r--r--python/ecdsa/ecdsa.SlackBuild6
1 files changed, 5 insertions, 1 deletions
diff --git a/python/ecdsa/ecdsa.SlackBuild b/python/ecdsa/ecdsa.SlackBuild
index 40450aaa0d2e..46c7a8eeaaa0 100644
--- a/python/ecdsa/ecdsa.SlackBuild
+++ b/python/ecdsa/ecdsa.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for ecdsa
-# Copyright 2013-2016 Willy Sudiarto Raharjo <willysr@slackbuilds.org>
+# Copyright 2013-2018 Willy Sudiarto Raharjo <willysr@slackbuilds.org>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -71,6 +71,10 @@ find -L . \
python setup.py install --root=$PKG
+if $(python3 -c 'import sys' 2>/dev/null); then
+ python3 setup.py install --root=$PKG
+fi
+
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true