aboutsummaryrefslogtreecommitdiff
path: root/python/cryptography/cryptography.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'python/cryptography/cryptography.SlackBuild')
-rw-r--r--python/cryptography/cryptography.SlackBuild9
1 files changed, 3 insertions, 6 deletions
diff --git a/python/cryptography/cryptography.SlackBuild b/python/cryptography/cryptography.SlackBuild
index 022524be14497..a2a609684dde0 100644
--- a/python/cryptography/cryptography.SlackBuild
+++ b/python/cryptography/cryptography.SlackBuild
@@ -3,6 +3,7 @@
# Slackware build script for cryptography
# Copyright 2014-2018 Markus Reichelt, Aachen, DE
+# Copyright 2021 Willy Sudiarto Raharjo <willysr@slackbuilds.org>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -22,12 +23,11 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
#
-# Markus Reichelt <slackbuilds@mareichelt.de>, 0xCCEEF115
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=cryptography
-VERSION=${VERSION:-2.8}
+VERSION=${VERSION:-35.0.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -40,9 +40,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -81,7 +78,7 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python2 setup.py install --root=$PKG
+sed -i '/install_requires/d' setup.py
python3 setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \