aboutsummaryrefslogtreecommitdiff
path: root/python/click-default-group/click-default-group.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'python/click-default-group/click-default-group.SlackBuild')
-rw-r--r--python/click-default-group/click-default-group.SlackBuild7
1 files changed, 6 insertions, 1 deletions
diff --git a/python/click-default-group/click-default-group.SlackBuild b/python/click-default-group/click-default-group.SlackBuild
index 23ab86fbda46..7bf8d2c4dfb8 100644
--- a/python/click-default-group/click-default-group.SlackBuild
+++ b/python/click-default-group/click-default-group.SlackBuild
@@ -2,6 +2,7 @@
# Slackware build script for click-default-group
+# Copyright 2022 fourtysixandtwo <fourtysixandtwo@sliderr.net>
# Copyright 2016 Dimitris Zlatanidis Orestiada, Greece
# All rights reserved.
#
@@ -22,10 +23,13 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+# 20220512 46and2: Updated version, added python3
+# 20220515 46and2: New maintainer.
+
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=click-default-group
-VERSION=${VERSION:-1.2}
+VERSION=${VERSION:-1.2.2}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -80,6 +84,7 @@ find -L . \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
python2 setup.py install --root=$PKG
+python3 setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true