aboutsummaryrefslogtreecommitdiff
path: root/python/billiard
diff options
context:
space:
mode:
Diffstat (limited to 'python/billiard')
-rw-r--r--python/billiard/README15
-rw-r--r--python/billiard/billiard.SlackBuild77
-rw-r--r--python/billiard/billiard.info10
-rw-r--r--python/billiard/slack-desc19
4 files changed, 0 insertions, 121 deletions
diff --git a/python/billiard/README b/python/billiard/README
deleted file mode 100644
index 7ea6254fd5c13..0000000000000
--- a/python/billiard/README
+++ /dev/null
@@ -1,15 +0,0 @@
-billiard is a fork of the Python 2.7 multiprocessing package.
-The multiprocessing package itself is a renamed and updated version of
-R Oudkerk's pyprocessing package.
-This standalone variant draws its fixes/improvements from python-trunk
-and provides additional bug fixes and improvements.
-
-* This package would not be possible if not for the contributions of not
- only the current maintainers but all of the contributors to the
- original pyprocessing package listed here.
-* Also, it is a fork of the multiprocessing backport package by
- Christian Heims.
-* It includes the no-execv patch contributed by R. Oudkerk.
-* And the Pool improvements previously located in Celery.
-* Billiard is used in and is a dependency for Celery and is maintained
- by the Celery team.
diff --git a/python/billiard/billiard.SlackBuild b/python/billiard/billiard.SlackBuild
deleted file mode 100644
index 48379a9115e27..0000000000000
--- a/python/billiard/billiard.SlackBuild
+++ /dev/null
@@ -1,77 +0,0 @@
-#!/bin/bash
-
-# SlackBuild script for billiard.
-# Yth | Pont-en-Royans, France | yth@ythogtha.org
-
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-cd $(dirname $0) ; CWD=$(pwd)
-
-PRGNAM=billiard
-VERSION=${VERSION:-3.3.0.23}
-BUILD=${BUILD:-2}
-TAG=${TAG:-_SBo}
-PKGTYPE=${PKGTYPE:-tgz}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
-if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
- echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
- exit 0
-fi
-
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
-cd $PRGNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-python setup.py install --root=$PKG
-python3 setup.py install --root=$PKG
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a README.rst $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/python/billiard/billiard.info b/python/billiard/billiard.info
deleted file mode 100644
index 913c1b99ee5bb..0000000000000
--- a/python/billiard/billiard.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="billiard"
-VERSION="3.3.0.23"
-HOMEPAGE="http://github.com/celery/billiard"
-DOWNLOAD="https://github.com/celery/billiard/archive/v3.3.0.23/billiard-3.3.0.23.tar.gz"
-MD5SUM="6185eab6fea29929730b396ccca423d0"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES=""
-MAINTAINER="Yth - Arnaud"
-EMAIL="yth@ythogtha.org"
diff --git a/python/billiard/slack-desc b/python/billiard/slack-desc
deleted file mode 100644
index 009b96e8c276b..0000000000000
--- a/python/billiard/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-billiard: billiard (Multiprocessing Pool Extensions)
-billiard:
-billiard: billiard is a fork of the Python 2.7 multiprocessing package.
-billiard:
-billiard: This standalone variant draws its fixes/improvements from
-billiard: python-trunk and provides additional bug fixes and improvements.
-billiard:
-billiard:
-billiard:
-billiard:
-billiard: