aboutsummaryrefslogtreecommitdiff
path: root/python/backlash
diff options
context:
space:
mode:
Diffstat (limited to 'python/backlash')
-rw-r--r--python/backlash/README9
-rw-r--r--python/backlash/backlash.SlackBuild6
2 files changed, 8 insertions, 7 deletions
diff --git a/python/backlash/README b/python/backlash/README
index e996c192aab9e..8c51e16ce3549 100644
--- a/python/backlash/README
+++ b/python/backlash/README
@@ -2,9 +2,12 @@ Backlash supports both debugging applications on crash and realtime
console, both are based on the Werkzeug Debugger and adapted to work
with WebOb.
-backlash is a swiss army knife for web applications debugging, which provides:
- An Interactive In Browser Debugger based on a Werkzeug Debugger fork ported to WebOb
+backlash is a swiss army knife for web applications debugging, which
+provides:
+ An Interactive In Browser Debugger based on a Werkzeug Debugger fork
+ ported to WebOb
Crash reporting by email and on Sentry
Slow requests reporting by email and on Sentry.
-Backlash was born as a replacement for WebError in TurboGears2.3 versions.
+Backlash was born as a replacement for WebError in TurboGears2.3
+versions.
diff --git a/python/backlash/backlash.SlackBuild b/python/backlash/backlash.SlackBuild
index 4f62b1c1c8b47..4c7f13a6ebe10 100644
--- a/python/backlash/backlash.SlackBuild
+++ b/python/backlash/backlash.SlackBuild
@@ -53,10 +53,8 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python setup.py install --root=$PKG
-if $(python3 -c 'import sys' 2>/dev/null); then
- python3 setup.py install --root=$PKG
-fi
+python2 setup.py install --root=$PKG
+python3 setup.py install --root=$PKG
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a README* MANIFEST.in $PKG/usr/doc/$PRGNAM-$VERSION