aboutsummaryrefslogtreecommitdiff
path: root/python/BeautifulSoup4/BeautifulSoup4.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'python/BeautifulSoup4/BeautifulSoup4.SlackBuild')
-rw-r--r--python/BeautifulSoup4/BeautifulSoup4.SlackBuild7
1 files changed, 2 insertions, 5 deletions
diff --git a/python/BeautifulSoup4/BeautifulSoup4.SlackBuild b/python/BeautifulSoup4/BeautifulSoup4.SlackBuild
index 6793e1369aa8d..ff38ba2659365 100644
--- a/python/BeautifulSoup4/BeautifulSoup4.SlackBuild
+++ b/python/BeautifulSoup4/BeautifulSoup4.SlackBuild
@@ -72,10 +72,7 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-# Python 2 support (requires python-soupsieve)
-if $(python2 -c 'import soupsieve' 2>/dev/null); then
- python setup.py install --root=$PKG
-fi
+python2 setup.py install --root=$PKG
# Python 3 support (requires python3-soupsieve)
# shaypal5 provided an example package check:
@@ -94,7 +91,7 @@ if $(python3 -c 'import pkgutil; exit(not pkgutil.find_loader("soupsieve"))'); t
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
- # Build for Python 3
+ # Build for Python 3
sed -i "s/-rfI/-rf/" convert-py3k
sh convert-py3k
python3 setup.py install --root=$PKG