aboutsummaryrefslogtreecommitdiff
path: root/office/pdftk/pdftk-1.41-slackware64-13.patch
diff options
context:
space:
mode:
Diffstat (limited to 'office/pdftk/pdftk-1.41-slackware64-13.patch')
-rw-r--r--office/pdftk/pdftk-1.41-slackware64-13.patch229
1 files changed, 229 insertions, 0 deletions
diff --git a/office/pdftk/pdftk-1.41-slackware64-13.patch b/office/pdftk/pdftk-1.41-slackware64-13.patch
new file mode 100644
index 000000000000..d3edd2bff573
--- /dev/null
+++ b/office/pdftk/pdftk-1.41-slackware64-13.patch
@@ -0,0 +1,229 @@
+diff -u -r pdftk-1.41-orig/java_libs/com/lowagie/bc/asn1/Makefile pdftk-1.41/java_libs/com/lowagie/bc/asn1/Makefile
+--- pdftk-1.41-orig/java_libs/com/lowagie/bc/asn1/Makefile 2006-07-28 01:18:06.000000000 +0200
++++ pdftk-1.41/java_libs/com/lowagie/bc/asn1/Makefile 2009-11-16 15:33:23.000000000 +0100
+@@ -25,8 +25,7 @@
+ # the "$*" automatic variable, here
+ #
+ %.h : %.class
+- $(GCJH) --classpath="." $*;
+- $(RM) $<
++ $(GCJH) --classpath="$(java_libs_root):." $*;
+
+ ##
+ # targets
+diff -u -r pdftk-1.41-orig/java_libs/com/lowagie/text/Makefile pdftk-1.41/java_libs/com/lowagie/text/Makefile
+--- pdftk-1.41-orig/java_libs/com/lowagie/text/Makefile 2006-07-26 23:14:34.000000000 +0200
++++ pdftk-1.41/java_libs/com/lowagie/text/Makefile 2009-11-16 15:33:23.000000000 +0100
+@@ -25,13 +25,12 @@
+ # the "$*" automatic variable, here
+ #
+ %.h : %.class
+- $(GCJH) --classpath="." $*;
+- $(RM) $<
++ $(GCJH) --classpath="$(java_libs_root):." $*;
+
+ ##
+ # targets
+
+-all : $(library) $(headers)
++all : $(library) $(headers) $(classes)
+
+ $(library) : $(objects)
+ $(AR) $(ARFLAGS) $(library) $(objects);
+diff -u -r pdftk-1.41-orig/java_libs/com/lowagie/text/markup/Makefile pdftk-1.41/java_libs/com/lowagie/text/markup/Makefile
+--- pdftk-1.41-orig/java_libs/com/lowagie/text/markup/Makefile 2006-07-26 23:14:54.000000000 +0200
++++ pdftk-1.41/java_libs/com/lowagie/text/markup/Makefile 2009-11-16 15:33:23.000000000 +0100
+@@ -25,8 +25,7 @@
+ # the "$*" automatic variable, here
+ #
+ %.h : %.class
+- $(GCJH) --classpath="." $*;
+- $(RM) $<
++ $(GCJH) --classpath="$(java_libs_root):." $*;
+
+ ##
+ # targets
+diff -u -r pdftk-1.41-orig/java_libs/com/lowagie/text/pdf/codec/Makefile pdftk-1.41/java_libs/com/lowagie/text/pdf/codec/Makefile
+--- pdftk-1.41-orig/java_libs/com/lowagie/text/pdf/codec/Makefile 2006-07-26 23:15:20.000000000 +0200
++++ pdftk-1.41/java_libs/com/lowagie/text/pdf/codec/Makefile 2009-11-16 15:37:55.000000000 +0100
+@@ -25,8 +25,7 @@
+ # the "$*" automatic variable, here
+ #
+ %.h : %.class
+- $(GCJH) --classpath="." $*;
+- $(RM) $<
++ $(GCJH) --classpath="$(java_libs_root):." $*;
+
+ ##
+ # targets
+diff -u -r pdftk-1.41-orig/java_libs/com/lowagie/text/pdf/codec/postscript/Makefile pdftk-1.41/java_libs/com/lowagie/text/pdf/codec/postscript/Makefile
+--- pdftk-1.41-orig/java_libs/com/lowagie/text/pdf/codec/postscript/Makefile 2006-07-28 01:21:06.000000000 +0200
++++ pdftk-1.41/java_libs/com/lowagie/text/pdf/codec/postscript/Makefile 2009-11-16 15:38:15.000000000 +0100
+@@ -25,8 +25,7 @@
+ # the "$*" automatic variable, here
+ #
+ %.h : %.class
+- $(GCJH) --classpath="." $*;
+- $(RM) $<
++ $(GCJH) --classpath="$(java_libs_root):." $*;
+
+ ##
+ # targets
+diff -u -r pdftk-1.41-orig/java_libs/com/lowagie/text/pdf/codec/wmf/Makefile pdftk-1.41/java_libs/com/lowagie/text/pdf/codec/wmf/Makefile
+--- pdftk-1.41-orig/java_libs/com/lowagie/text/pdf/codec/wmf/Makefile 2006-07-26 23:15:32.000000000 +0200
++++ pdftk-1.41/java_libs/com/lowagie/text/pdf/codec/wmf/Makefile 2009-11-16 15:38:34.000000000 +0100
+@@ -25,8 +25,7 @@
+ # the "$*" automatic variable, here
+ #
+ %.h : %.class
+- $(GCJH) --classpath="." $*;
+- $(RM) $<
++ $(GCJH) --classpath="$(java_libs_root):." $*;
+
+ ##
+ # targets
+diff -u -r pdftk-1.41-orig/java_libs/com/lowagie/text/pdf/fonts/Makefile pdftk-1.41/java_libs/com/lowagie/text/pdf/fonts/Makefile
+--- pdftk-1.41-orig/java_libs/com/lowagie/text/pdf/fonts/Makefile 2006-07-26 23:15:48.000000000 +0200
++++ pdftk-1.41/java_libs/com/lowagie/text/pdf/fonts/Makefile 2009-11-16 15:33:23.000000000 +0100
+@@ -34,8 +34,7 @@
+ # the "$*" automatic variable, here
+ #
+ %.h : %.class
+- $(GCJH) --classpath="." $*;
+- $(RM) $<
++ $(GCJH) --classpath="$(java_libs_root):." $*;
+
+ ##
+ # targets
+diff -u -r pdftk-1.41-orig/java_libs/com/lowagie/text/pdf/Makefile pdftk-1.41/java_libs/com/lowagie/text/pdf/Makefile
+--- pdftk-1.41-orig/java_libs/com/lowagie/text/pdf/Makefile 2006-07-26 23:15:10.000000000 +0200
++++ pdftk-1.41/java_libs/com/lowagie/text/pdf/Makefile 2009-11-16 15:33:23.000000000 +0100
+@@ -25,8 +25,7 @@
+ # the "$*" automatic variable, here
+ #
+ %.h : %.class
+- $(GCJH) --classpath="." $*;
+- $(RM) $<
++ $(GCJH) --classpath="$(java_libs_root):." $*;
+
+ ##
+ # targets
+diff -u -r pdftk-1.41-orig/java_libs/com/lowagie/text/pdf/PdfDate.java pdftk-1.41/java_libs/com/lowagie/text/pdf/PdfDate.java
+--- pdftk-1.41-orig/java_libs/com/lowagie/text/pdf/PdfDate.java 2006-07-27 01:56:42.000000000 +0200
++++ pdftk-1.41/java_libs/com/lowagie/text/pdf/PdfDate.java 2009-11-16 15:33:37.000000000 +0100
+@@ -76,7 +76,7 @@
+ // ssteward; static builds of pdftk (Windows, gcc 3.3.1) would
+ // omit this class because of its reference by reflection;
+ // this treatment ensures that ld will include it
+- private static Class c1= gnu.java.locale.Calendar.class;
++ private static Class c1= java.util.Calendar.class;
+
+ private static final int dateSpace[] = {Calendar.YEAR, 4, 0, Calendar.MONTH, 2, -1, Calendar.DAY_OF_MONTH, 2, 0,
+ Calendar.HOUR_OF_DAY, 2, 0, Calendar.MINUTE, 2, 0, Calendar.SECOND, 2, 0};
+diff -u -r pdftk-1.41-orig/java_libs/com/lowagie/text/pdf/PdfEncryption.java pdftk-1.41/java_libs/com/lowagie/text/pdf/PdfEncryption.java
+--- pdftk-1.41-orig/java_libs/com/lowagie/text/pdf/PdfEncryption.java 2006-07-27 02:02:28.000000000 +0200
++++ pdftk-1.41/java_libs/com/lowagie/text/pdf/PdfEncryption.java 2009-11-16 15:46:10.000000000 +0100
+@@ -50,7 +50,7 @@
+
+ package com.lowagie.text.pdf;
+
+-import java_local.security.MessageDigest; // ssteward
++import java.security.MessageDigest;
+ import com.lowagie.text.ExceptionConverter;
+
+ /**
+diff -u -r pdftk-1.41-orig/java_libs/com/lowagie/text/xml/xmp/Makefile pdftk-1.41/java_libs/com/lowagie/text/xml/xmp/Makefile
+--- pdftk-1.41-orig/java_libs/com/lowagie/text/xml/xmp/Makefile 2006-07-27 02:53:34.000000000 +0200
++++ pdftk-1.41/java_libs/com/lowagie/text/xml/xmp/Makefile 2009-11-16 15:33:23.000000000 +0100
+@@ -25,8 +25,7 @@
+ # the "$*" automatic variable, here
+ #
+ %.h : %.class
+- $(GCJH) --classpath="." $*;
+- $(RM) $<
++ $(GCJH) --classpath="$(java_libs_root):." $*;
+
+ ##
+ # targets
+diff -u -r pdftk-1.41-orig/java_libs/Makefile pdftk-1.41/java_libs/Makefile
+--- pdftk-1.41-orig/java_libs/Makefile 2006-08-29 08:44:26.000000000 +0200
++++ pdftk-1.41/java_libs/Makefile 2009-11-16 15:33:23.000000000 +0100
+@@ -13,13 +13,7 @@
+ # append gcj flags
+ export GCJFLAGS+= --encoding=UTF-8 --classpath="$(java_libs_root)"
+
+-all : libgcj_local itext
+-
+-libgcj_local :
+- $(MAKE) -C "$(java_libs_root)/gnu_local/java/security";
+- $(MAKE) -C "$(java_libs_root)/gnu_local/java/security/provider";
+- $(MAKE) -C "$(java_libs_root)/gnu/gcj/convert";
+- $(MAKE) -C "$(java_libs_root)/java_local/security";
++all : itext
+
+ itext :
+ $(MAKE) -C "$(java_libs_root)/com/lowagie/text";
+@@ -35,13 +29,7 @@
+ $(MAKE) -C "$(java_libs_root)/com/lowagie/bc/asn1";
+ $(MAKE) -C "$(java_libs_root)/com/lowagie/text/pdf/codec/postscript";
+
+-clean : libgcj_local_clean itext_clean
+-
+-libgcj_local_clean :
+- $(MAKE) -iC "$(java_libs_root)/gnu_local/java/security" clean;
+- $(MAKE) -iC "$(java_libs_root)/gnu_local/java/security/provider" clean;
+- $(MAKE) -iC "$(java_libs_root)/gnu/gcj/convert" clean;
+- $(MAKE) -iC "$(java_libs_root)/java_local/security" clean;
++clean : itext_clean
+
+ itext_clean :
+ $(MAKE) -iC "$(java_libs_root)/com/lowagie/text" clean;
+diff -u -r pdftk-1.41-orig/pdftk/Makefile.Base pdftk-1.41/pdftk/Makefile.Base
+--- pdftk-1.41-orig/pdftk/Makefile.Base 2006-10-25 01:44:06.000000000 +0200
++++ pdftk-1.41/pdftk/Makefile.Base 2009-11-16 15:36:00.000000000 +0100
+@@ -31,18 +31,6 @@
+ afms= $(wildcard $(java_libs_root)/com/lowagie/text/pdf/fonts/*.afm)
+ afm_objects= $(patsubst %.afm, %.o, $(afms))
+
+-# older versions of libgcj might not have the MD5 algorithm,
+-# so I added it here; these *_local java files were grabbed from
+-# libgcj CVS on March 7, 2004; diffed September 5, 2006 w/ gcc 4.1.1
+-#
+-# gnu/gcj/convert/Input_UnicodeBig.java was grabbed March 26, 2004; diffed September 5, 2006 w/ gcc 4.1.1
+-#
+-libgcj_local_libs = \
+-$(java_libs_root)/java_local/security/security.a \
+-$(java_libs_root)/gnu_local/java/security/provider/provider.a \
+-$(java_libs_root)/gnu_local/java/security/security.a \
+-$(java_libs_root)/gnu/gcj/convert/convert.a
+-
+ # this must already be set according to your platform Makefile;
+ # we're just appending to it, here
+ #
+@@ -63,10 +51,10 @@
+ $(CXX) pdftk.cc -I$(java_libs_root) $(CPPFLAGS) -c
+
+ pdftk : pdftk.o attachments.o report.o $(itext_libs) $(libgcj_local_libs) $(afm_objects)
+- $(CXX) pdftk.o attachments.o report.o $(itext_libs) $(libgcj_local_libs) $(afm_objects) -I$(java_libs_root) $(CPPFLAGS) $(CXXFLAGS) -o pdftk
++ $(CXX) pdftk.o attachments.o report.o $(itext_libs) $(libgcj_local_libs) $(afm_objects) -I$(java_libs_root) $(CPPFLAGS) $(CXXFLAGS) $(LDFLAGS) -o pdftk
+
+ install:
+- /usr/bin/install pdftk /usr/local/bin
++ /usr/bin/install pdftk $(DESTDIR)$(PREFIX)/bin
+
+ uninstall:
+ rm -vf /usr/local/bin/pdftk
+diff -u -r pdftk-1.41-orig/pdftk/Makefile.Generic pdftk-1.41/pdftk/Makefile.Generic
+--- pdftk-1.41-orig/pdftk/Makefile.Generic 2006-09-21 19:37:12.000000000 +0200
++++ pdftk-1.41/pdftk/Makefile.Generic 2009-11-16 15:35:27.000000000 +0100
+@@ -10,6 +10,10 @@
+ # Clean: make -f Makefile.Generic clean
+ #
+
++# prefixes and destination dir for packaging
++PREFIX= /usr/local
++DESTDIR=
++
+ # tools
+ TOOLPATH=
+ VERSUFF=