aboutsummaryrefslogtreecommitdiff
path: root/office/marave/marave.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'office/marave/marave.SlackBuild')
-rw-r--r--office/marave/marave.SlackBuild11
1 files changed, 6 insertions, 5 deletions
diff --git a/office/marave/marave.SlackBuild b/office/marave/marave.SlackBuild
index 63b61316ddd58..db45addc72b24 100644
--- a/office/marave/marave.SlackBuild
+++ b/office/marave/marave.SlackBuild
@@ -22,6 +22,10 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+# 20220218 bkw: Modified by SlackBuilds.org: host the source somewhere
+# besides github, since it's "master.zip": the next time someone commits
+# to the upstream repo, the md5sum will change.
+
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=marave
@@ -39,9 +43,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -76,9 +77,9 @@ cd $PRGNAM-$SRCVER
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
+ -o -perm 511 \) -exec chmod 755 {} \+ -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \+
python setup.py install --root=$PKG