aboutsummaryrefslogtreecommitdiff
path: root/office/gnucash/gnucash.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'office/gnucash/gnucash.SlackBuild')
-rw-r--r--office/gnucash/gnucash.SlackBuild8
1 files changed, 7 insertions, 1 deletions
diff --git a/office/gnucash/gnucash.SlackBuild b/office/gnucash/gnucash.SlackBuild
index 282dadf39ca8f..c4d74d46a50af 100644
--- a/office/gnucash/gnucash.SlackBuild
+++ b/office/gnucash/gnucash.SlackBuild
@@ -27,7 +27,7 @@ cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=gnucash
VERSION=${VERSION:-4.11}
-BUILD=${BUILD:-2}
+BUILD=${BUILD:-3}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -119,6 +119,12 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+if $(pkg-config --exists webkit2gtk4.1); then
+ #use webkit2gtk4.1 instead of webkit2gtk if present.
+ sed -i 's/webkit2gtk-4.0/webkit2gtk-4.1/g' CMakeLists.txt
+ sed -i 's/WebKit2Gtk4/WebKit2Gtk4.1/g' CMakeLists.txt
+fi
+
mkdir -p build
cd build
cmake \