aboutsummaryrefslogtreecommitdiff
path: root/office/abook/abook.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'office/abook/abook.SlackBuild')
-rw-r--r--office/abook/abook.SlackBuild25
1 files changed, 16 insertions, 9 deletions
diff --git a/office/abook/abook.SlackBuild b/office/abook/abook.SlackBuild
index 4097741c4e75..45031e240bcb 100644
--- a/office/abook/abook.SlackBuild
+++ b/office/abook/abook.SlackBuild
@@ -2,6 +2,7 @@
# Slackware build script for abook
+# Copyright 2017 Frédéric Galusik, Lyon, France
# Copyright 2006 Martin Lefebvre <dadexter@gmail.com>
# Copyright 2007-2009 Michiel van Wessem, Manchester, United Kingdom
@@ -25,7 +26,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=abook
-VERSION=${VERSION:-0.5.6}
+VERSION=${VERSION:-0.6.1}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -56,10 +57,8 @@ else
LIBDIRSUFFIX=""
fi
-
set -e
-
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
@@ -75,24 +74,32 @@ find -L . \
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
+aclocal && automake --add-missing && autoconf
+sed 's/0.18/0.19/g' -i po/Makefile.in.in
+# thanks to the archers for this patch ;)
+patch -p1 -i $CWD/gcc5.patch
+
./configure \
--prefix=/usr \
--libdir=/usr/lib${LIBDIRSUFFIX} \
--sysconfdir=/etc \
--mandir=/usr/man \
--localstatedir=/var \
+ --build=$ARCH-slackware-linux
make
-make install-strip DESTDIR=$PKG
+make install DESTDIR=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-( cd $PKG/usr/man
- find . -type f -exec gzip -9 {} \;
- for i in $( find . -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
-)
+find $PKG/usr/man -type f -exec gzip -9 {} \;
+for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a ABOUT-NLS ANNOUNCE AUTHORS BUGS COPYING ChangeLog FAQ INSTALL NEWS \
- README THANKS TODO $PKG/usr/doc/$PRGNAM-$VERSION
+ README RELEASE_NOTES THANKS TODO doc/HOWTO.translating_abook \
+ $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install