aboutsummaryrefslogtreecommitdiff
path: root/network/toot/toot.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'network/toot/toot.SlackBuild')
-rw-r--r--network/toot/toot.SlackBuild21
1 files changed, 2 insertions, 19 deletions
diff --git a/network/toot/toot.SlackBuild b/network/toot/toot.SlackBuild
index 3c21ba10c4650..e1e0e8701f0ce 100644
--- a/network/toot/toot.SlackBuild
+++ b/network/toot/toot.SlackBuild
@@ -25,16 +25,13 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=toot
-VERSION=${VERSION:-0.38.1}
+VERSION=${VERSION:-0.38.2}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
ARCH=${ARCH:-noarch}
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -61,29 +58,15 @@ find -L . \
python3 setup.py install --root=$PKG
-# Strip binaries and libraries.
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-# If the man pages are installed to /usr/share/man instead, you'll need to
-# move them manually.
-find $PKG/usr/man -type f -exec gzip -9 {} \;
-for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
-
-rmdir --ignore-fail-on-non-empty $PKG/usr/man
-
-# Also, include the SlackBuild script in the documentation directory
+rm -rf $PKG/usr/man
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-# cp -a \
-# $TMP/$PRGNAM-$VERSION/docs/ \
-# $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
-# If package symlinks need to be created during install *before*
-# your custom contents of doinst.sh runs, then add the -p switch to
-# the makepkg command below -- see makepkg(8) for details
cd $PKG
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE