aboutsummaryrefslogtreecommitdiff
path: root/network/netsurf/netsurf.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'network/netsurf/netsurf.SlackBuild')
-rw-r--r--network/netsurf/netsurf.SlackBuild21
1 files changed, 4 insertions, 17 deletions
diff --git a/network/netsurf/netsurf.SlackBuild b/network/netsurf/netsurf.SlackBuild
index fe748e5d17d9..649dd16b9ad8 100644
--- a/network/netsurf/netsurf.SlackBuild
+++ b/network/netsurf/netsurf.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for netsurf
-# Copyright 2012 - 2015 Ruben Schuller
+# Copyright 2012 - 2018 Ruben Schuller
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -23,7 +23,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=netsurf
-VERSION=${VERSION:-3.3}
+VERSION=${VERSION:-3.8}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -69,23 +69,10 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \;
-if [ "${NETSURF_USE_VIDEO:-NO}"=="YES" ]; then
- patch --verbose -p1 < $CWD/enable-deprecated.diff
-fi
-
-sed \
- -e 's:_BSD_SOURCE:_DEFAULT_SOURCE:' \
- -e 's:(WARNFLAGS) -Werror:(WARNFLAGS):' \
- -i */Makefile */*/Makefile.target
-
-make install DESTDIR=$PKG PREFIX=/usr \
- NETSURF_USE_MOZJS=${NETSURF_USE_MOZJS:-YES} \
- NETSURF_USE_WEBP=${NETSURF_USE_WEBP:-NO} \
- NETSURF_USE_VIDEO=${NETSURF_USE_VIDEO:-NO}
+make install DESTDIR=$PKG PREFIX=/usr
mkdir -p $PKG/usr/share/pixmaps
-cp netsurf/gtk/res/netsurf.png $PKG/usr/share/pixmaps
-cp netsurf/gtk/res/netsurf.xpm $PKG/usr/share/pixmaps
+cp netsurf/resources/netsurf.png $PKG/usr/share/pixmaps
mkdir -p $PKG/usr/share/applications
cp $CWD/netsurf.desktop $PKG/usr/share/applications