aboutsummaryrefslogtreecommitdiff
path: root/network/libressl/libressl.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'network/libressl/libressl.SlackBuild')
-rw-r--r--network/libressl/libressl.SlackBuild46
1 files changed, 23 insertions, 23 deletions
diff --git a/network/libressl/libressl.SlackBuild b/network/libressl/libressl.SlackBuild
index 6242e41b1ec8..4fb27ddd6aed 100644
--- a/network/libressl/libressl.SlackBuild
+++ b/network/libressl/libressl.SlackBuild
@@ -4,10 +4,20 @@
#
# WTFPL licence
+# BUILD 2: Thanks to Naglfar:
+#
+# --with-openssldir=/etc/$PRGNAM \
+#
+# NOTE: PKG_CONFIG_PATH will likely need setting in your build scripts:
+#
+# PKG_CONFIG_PATH=/usr/lib$LIBDIRSUFFIX/libressl/pkgconfig:$PKG_CONFIG_PATH \
+# ./configure \
+# ...
+
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=libressl
-VERSION=${VERSION:-3.7.0}
+VERSION=${VERSION:-3.7.1}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -55,46 +65,39 @@ chown -R root:root .
find . -perm /111 -a \! -perm 755 -a -exec chmod 755 {} + \
-o \! -perm /111 -a \! -perm 644 -a -exec chmod 644 {} +
+# Don't install man page symlinks
+sed -i '/ln -sf.*\.3"$/d' man/Makefile.in
+
if [ "${MANPAGES:-no}" = no ]; then
sed -i '/man\/Makefile/d' configure.ac
autoreconf -f
sed -i "s, man , ,g; s, install-man , ,g" Makefile.in
fi
-PREFIX=/opt/$PRGNAM
-
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
./configure \
--enable-nc \
--disable-tests \
--disable-static \
- --prefix=$PREFIX \
- --libdir=$PREFIX/lib${LIBDIRSUFFIX} \
- --sysconfdir=$PREFIX/etc \
- --mandir=$PREFIX/man \
+ --prefix=/usr \
+ --libdir=/usr/lib${LIBDIRSUFFIX}/$PRGNAM \
+ --includedir=/usr/include/$PRGNAM \
+ --with-openssldir=/etc/$PRGNAM \
+ --program-prefix "$PRGNAM-" \
+ --mandir=/usr/man \
--docdir=/usr/doc/$PRGNAM-$VERSION \
--build=$ARCH-slackware-linux
make
make install DESTDIR=$PKG
-rm -f $PKG$PREFIX/{,usr/}lib${LIBDIRSUFFIX}/*.la
-
-mkdir -p $PKG/usr/bin
-( cd $PKG/usr/bin ; ln -sf ../..$PREFIX/bin/nc nc-tls )
-( cd $PKG/usr/bin ; ln -sf ../..$PREFIX/bin/openssl libre-openssl )
-( cd $PKG/usr/bin ; ln -sf ../..$PREFIX/bin/ocspcheck libre-ocspcheck )
-
-mv $PKG$PREFIX/man/man1/nc.1 $PKG$PREFIX/man/man1/nc-tls.1
-mv $PKG$PREFIX/man/man1/openssl.1 $PKG$PREFIX/man/man1/libre-openssl.1
-mv $PKG$PREFIX/man/man8/ocspcheck.8 $PKG$PREFIX/man/man8/libre-ocspcheck.8
+rm -f $PKG/usr/lib${LIBDIRSUFFIX}/$PRGNAM/*.la
-find $PKG$PREFIX/man -type f -exec gzip -9 {} \;
-for i in $( find $PKG$PREFIX/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
+find $PKG/usr/man -type f -exec gzip -9 {} \;
mkdir -p $PKG/etc/ld.so.conf.d/
-echo $PREFIX/lib${LIBDIRSUFFIX} > $PKG/etc/ld.so.conf.d/$PRGNAM.conf
+echo /usr/lib${LIBDIRSUFFIX}/$PRGNAM > $PKG/etc/ld.so.conf.d/$PRGNAM.conf
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
@@ -114,7 +117,4 @@ cat $CWD/doinst.sh > $PKG/install/doinst.sh
cat $CWD/douninst.sh > $PKG/install/douninst.sh
cd $PKG
-find . -type l \
- -printf '( cd %h ; rm -rf %f )\n( cd %h ; ln -sf %l %f )\n' -delete | \
- sed 's,cd \./,cd ,' >> $PKG/install/doinst.sh
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE