aboutsummaryrefslogtreecommitdiff
path: root/network/allmydata-tahoe/allmydata-tahoe.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'network/allmydata-tahoe/allmydata-tahoe.SlackBuild')
-rw-r--r--network/allmydata-tahoe/allmydata-tahoe.SlackBuild16
1 files changed, 7 insertions, 9 deletions
diff --git a/network/allmydata-tahoe/allmydata-tahoe.SlackBuild b/network/allmydata-tahoe/allmydata-tahoe.SlackBuild
index baebb063db0e..4a5ee97af272 100644
--- a/network/allmydata-tahoe/allmydata-tahoe.SlackBuild
+++ b/network/allmydata-tahoe/allmydata-tahoe.SlackBuild
@@ -1,9 +1,9 @@
#!/bin/sh
-# Slackware build script for allmydata-tahoe.
+# Slackware build script for allmydata-tahoe
# Copyright 2009 Marco Bonetti <sid77@slackware.it>
-# Copyright 2011,2012,2013 Markus Reichelt, Stolberg, DE
+# Copyright 2011-2015 Markus Reichelt, Stolberg, DE
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -27,7 +27,7 @@
# Now maintained by Markus Reichelt <slackbuilds@mareichelt.de>, 0xCCEEF115
PRGNAM=allmydata-tahoe
-VERSION=${VERSION:-1.10.0}
+VERSION=${VERSION:-1.10.1}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -69,9 +69,9 @@ cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 -o -perm 440 \
+ -o -perm 400 \) -exec chmod 644 {} \;
python setup.py install --root=$PKG
@@ -79,9 +79,7 @@ find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | gr
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION $PKG/usr/man/man1
-cp -a \
- COPYING.* *.txt NEWS.* CREDITS misc docs \
- $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a COPYING.* *.txt NEWS.* CREDITS misc docs $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mv $PKG/usr/doc/$PRGNAM-$VERSION/docs/man/tahoe.1 $PKG/usr/man/man1