aboutsummaryrefslogtreecommitdiff
path: root/network/PySocks/PySocks.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'network/PySocks/PySocks.SlackBuild')
-rw-r--r--network/PySocks/PySocks.SlackBuild7
1 files changed, 6 insertions, 1 deletions
diff --git a/network/PySocks/PySocks.SlackBuild b/network/PySocks/PySocks.SlackBuild
index 4d7b603995de..0c37c9230981 100644
--- a/network/PySocks/PySocks.SlackBuild
+++ b/network/PySocks/PySocks.SlackBuild
@@ -23,7 +23,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=PySocks
-VERSION=${VERSION:-1.5.7}
+VERSION=${VERSION:-1.6.8}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -71,6 +71,11 @@ find -L . \
python setup.py install --root=$PKG
+# Python 3 support.
+if $(python3 -c 'import sys' 2>/dev/null); then
+ python3 setup.py install --root=$PKG
+fi
+
find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true