aboutsummaryrefslogtreecommitdiff
path: root/multimedia/xbmc/patches/non-sse2-cpu.patch
diff options
context:
space:
mode:
Diffstat (limited to 'multimedia/xbmc/patches/non-sse2-cpu.patch')
-rw-r--r--multimedia/xbmc/patches/non-sse2-cpu.patch27
1 files changed, 18 insertions, 9 deletions
diff --git a/multimedia/xbmc/patches/non-sse2-cpu.patch b/multimedia/xbmc/patches/non-sse2-cpu.patch
index 0af727f2f7f82..ebf927c1aca73 100644
--- a/multimedia/xbmc/patches/non-sse2-cpu.patch
+++ b/multimedia/xbmc/patches/non-sse2-cpu.patch
@@ -1,12 +1,21 @@
-diff -Naur xbmc-10.00.orig/xbmc/lib/libsquish/Makefile.in xbmc-10.00/xbmc/lib/libsquish/Makefile.in
---- xbmc-10.00.orig/xbmc/lib/libsquish/Makefile.in 2010-05-18 07:29:17.000000000 +0000
-+++ xbmc-10.00/xbmc/lib/libsquish/Makefile.in 2010-10-29 03:17:26.000000000 +0000
-@@ -8,7 +8,7 @@
- ifeq ($(ARCH),arm)
- CXXFLAGS+=-I.
+diff -Naur xbmc-11.0-Eden_beta1.orig/lib/libsquish/Makefile.in xbmc-11.0-Eden_beta1/lib/libsquish/Makefile.in
+--- xbmc-11.0-Eden_beta1.orig/lib/libsquish/Makefile.in 2011-12-23 03:12:21.000000000 +0000
++++ xbmc-11.0-Eden_beta1/lib/libsquish/Makefile.in 2012-01-02 20:14:20.792407216 +0000
+@@ -15,7 +15,7 @@
+ ifeq ($(findstring powerpc,$(ARCH)),powerpc)
+ CXXFLAGS+=-DSQUISH_USE_ALTIVEC=1 -maltivec
+ else ifeq ($(findstring x86,$(ARCH)), x86)
+- CXXFLAGS+=-DSQUISH_USE_SSE=2 -msse2
++ CXXFLAGS+=-DSQUISH_USE_SSE=1 -msse
+ endif
+
+ LIB=libsquish.a
+@@ -30,7 +30,7 @@
+ ifeq ($(findstring osx,$(ARCH)),osx)
+ g++ -m32 -DSQUISH_USE_SSE=2 -msse2 -I. $(SRCS) -dynamiclib -install_name `pwd`/libsquish-native.so -o $@
else
--CXXFLAGS+=-I. -DSQUISH_USE_SSE=2 -msse2
-+CXXFLAGS+=-I. -DSQUISH_USE_SSE=1 -msse
+- g++ -DSQUISH_USE_SSE=2 -msse2 -I. $(SRCS) -shared -fPIC -Wl,-soname,`pwd`/libsquish-native.so -o $@
++ g++ -DSQUISH_USE_SSE=1 -msse -I. $(SRCS) -shared -fPIC -Wl,-soname,`pwd`/libsquish-native.so -o $@
endif
endif
- LIB=libsquish-@ARCH@.a
+