aboutsummaryrefslogtreecommitdiff
path: root/libraries/tepl/tepl.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'libraries/tepl/tepl.SlackBuild')
-rw-r--r--libraries/tepl/tepl.SlackBuild12
1 files changed, 10 insertions, 2 deletions
diff --git a/libraries/tepl/tepl.SlackBuild b/libraries/tepl/tepl.SlackBuild
index c4e2fbf721cd5..6a6195bfca416 100644
--- a/libraries/tepl/tepl.SlackBuild
+++ b/libraries/tepl/tepl.SlackBuild
@@ -30,7 +30,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=tepl
-VERSION=${VERSION:-6.4.0}
+VERSION=${VERSION:-6.8.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -81,8 +81,15 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+# circunvent meson version mismtach (fs.copyfile not available)
+# avoid gtk_doc, which uses fs.copyfile
+# replace unnecesary version bump of gio-2.0
+sed -i "s/meson_version: '>= 0.64'/meson_version: '>= 0.59'/;
+ s/'gio-2.0', version: '>= 2.74'/'gio-2.0', version: '>= 2.70'/" meson.build
+
+
cd build
- CFLAGS="$SLKCFLAGS" \
+ CFLAGS="$SLKCFLAGS -DG_CONNECT_DEFAULT=0" \
CXXFLAGS="$SLKCFLAGS" \
meson .. \
--buildtype=release \
@@ -92,6 +99,7 @@ cd build
--mandir=/usr/man \
--prefix=/usr \
--sysconfdir=/etc \
+ -Dgtk_doc=false \
-Dstrip=true
"${NINJA:=ninja}"
DESTDIR=$PKG $NINJA install