aboutsummaryrefslogtreecommitdiff
path: root/libraries/simplejson/setup.py.patch
diff options
context:
space:
mode:
Diffstat (limited to 'libraries/simplejson/setup.py.patch')
-rw-r--r--libraries/simplejson/setup.py.patch22
1 files changed, 22 insertions, 0 deletions
diff --git a/libraries/simplejson/setup.py.patch b/libraries/simplejson/setup.py.patch
new file mode 100644
index 000000000000..da22d796ffa8
--- /dev/null
+++ b/libraries/simplejson/setup.py.patch
@@ -0,0 +1,22 @@
+diff -Naur simplejson-2.0.9.orig/setup.py simplejson-2.0.9/setup.py
+--- simplejson-2.0.9.orig/setup.py 2009-02-18 23:39:19.000000000 +0000
++++ simplejson-2.0.9/setup.py 2009-04-13 04:34:39.000000000 +0000
+@@ -1,17 +1,7 @@
+ #!/usr/bin/env python
+
+-from ez_setup import use_setuptools
++import setuptools
+ import sys
+-if 'cygwin' in sys.platform.lower():
+- min_version='0.6c6'
+-else:
+- min_version='0.6a9'
+-try:
+- use_setuptools(min_version=min_version)
+-except TypeError:
+- # If a non-local ez_setup is already imported, it won't be able to
+- # use the min_version kwarg and will bail with TypeError
+- use_setuptools()
+
+ from setuptools import setup, find_packages, Extension, Feature
+ from distutils.command.build_ext import build_ext